My 1969 Datsun 521 kingcab diesel

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#161

Post by wayno » Wed Feb 26, 2020 12:08 pm

I forgot to put the block breather box/tube/assembly on the block and I took it for a test drive, it is vented to air but the way it is made oil gets blown into the box and then drains back into the block, well it just blew everywhere in that area, it soaked the exhaust pipe so I am kinda wondering why it was not smoking badly, when I pulled it into the driveway it did not soak the ground, so it likely was not that bad of a leak.
I was lucky to get it in there as it is tucked up on the block behind the stock exhaust manifold outlet that doesn't exist on this engine anymore, there really isn't a lot of room in this engine compartment to work on things.

This is the block breather/assembly on a spare engine in the garage.
Image

Here it is in my engine compartment, this is looking down between the exhaust manifold and the firewall.
Image

I put the part and my arm into that black hole in the front of the engine compartment to get it in there and mounted, it took a while and I had to play with that engine in my garage to understand what angle the bolt went in to find the threads to mount it.
Image

It was half a quart down, might have been half a quart down when I started the test drive, it ran just fine, I did notice at 70mph the EGTs are 200 degrees hotter now, and the EGTs rise faster also, being it normally ran at 600 degrees before and it rarely went over a 1000 degrees I am not worried, and when it did get up to 1400 degrees(3 years ago?) a long time ago when I first put the turbocharger on it likely didn't hurt it then either as I would think I would have had issues by now if any damage had occurred.
I am not going to like the EGTs being at 800 degrees, but I will get used to it, I was only on the freeway for around 3 miles, I need a longer drive to really determine anything conclusive.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#162

Post by wayno » Wed Feb 26, 2020 6:01 pm

I did a little floor board covering, I put matting on the floor, then I cut that vinyl cover I had in half and installed it in this truck, it's a really dirty blue but it looks alright for now, I put my wore out Datsun mats on top of the vinyl covering.
Image

Image

Here is the Air Heater Element installed under the throttle body, the red wire is ground, the black wire is 12V, it just turned out that way wire length wise, I didn't have a red wire the right length/gauge.
Image

Image
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#163

Post by wayno » Fri Feb 28, 2020 4:21 pm

Today I decided I wanted some kind of light in the truck at night, when I made the kingcab the dome light wiring got cut, so I re-wired it with an in-switched power source(always hot) which was kinda a pain, and then I wired it to the old headlight switch in the dash, I seriously doubt I will be able to see much unless I replace the bulb with a bright LED, but at least I have that option now, the dome light works.
My doors do not have a button/switch to turn on the dome light, and the holes that would appear to be for the button/switch are being used for my speaker wires in the doors, I will not be changing that, the old headlight switch in the dash is good enough for me.

Image

Image

This morning I also re-adjusted the box on the frame, it has always been slightly crooked, so I removed the custom mount bar/bracket and ovalled the holes so I could slide the front of the box towards the passenger side a 1/4", it better than it was before, but nothing is perfect.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#164

Post by wayno » Wed Apr 22, 2020 8:10 pm

After years of looking it appears I finally found another Subaru XT turbocharger(used), I hope it's the same one that is on my engine now, I will take photos when it arrives, it appears to be the same.
It was a little more expensive than the one on the engine now, but I bought that one used back in 2011? for $50.00 as I recall and it sat around for 6 or 7 years, I was so lucky I found that turbo and luckier that it worked out so great.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#165

Post by wayno » Sat Aug 15, 2020 6:34 pm

I received these today, the engine has not been starting all that well the first start of the day, I am hoping these will fix that issue.
Image

Image
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#166

Post by wayno » Sun Aug 16, 2020 12:52 pm

I put the glow plugs in today, kinda hot out to be doing this type of stuff(97 degrees), but I have a hard time getting to sleep when it is above 70 degrees, so I wake up late and get a late start doing things.
I don't know how they work yet other than it took a little more cranking before it started, but it was a lot smoother after it started, if it continues to crank that long next time I will remove the oil pressure switch wire and see if it starts right up, if it does then it is that switch, this system requires oil pressure before it will allow the engine to start.
This 521 kingcab turbo diesel is hard to work on in the engine compartment, there is no room for my hands anywhere except the stuff on the top layer, here is the back glow plug, it is the easiest to get to.
Image

Here is #3 glow plug, it is the hardest to get to, I had to use a mirror to be able to see it to put the wire on it and tighten it down, I could not see what I was taking a photo of as I could barely get the camera in there to get this photo.

Image

And here is #1 and #2 glow plugs, the only reason they are not the hardest is because I can see them, if I were to remove the injection lines I could get to them easier, but then it would be much harder to get started and I don't like turning it over a long time anymore, it is hard on starters.

Image

This is the area I am working in.

Image

I guess it is time to change the oil, I really didn't notice that I had put 5556 miles on this oil in just over 3 years, I didn't realize I drove it that much, it hardly ever needs oil and I expect most of it leaks out rather than being burned.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#167

Post by wayno » Mon Aug 17, 2020 1:00 pm

Once it starts it runs way smoother and will idle without missing, but it is very warm out right now, but it was very warm out before I changed them and it missed like crazy and would die if my foot was not deep into the pedal.
It still doesn't start as fast as the 720 engine does, but that oil pressure sensor wire is not connected on that engine as it will not start at all with it connected, I might try starting the 521 without that wire connected to see how much it changes the starting characteristics, that 720 engine starts so easy even when cold outside, it can sit for 6 months and it fires right up easier than my 521 starts after sitting one night.
It runs great though, I would rather drive the 521 kingcab turbodiesel than anything else I own.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#168

Post by wayno » Sun Nov 29, 2020 1:41 am

So on my way home from Thanksgiving dinner my headlights started to get brighter and dimmer, kind of pulsing, the dash lights were doing it also, very annoying, so this morning I check everything and the glow plug light was acting weird, it would just blink instead of staying on, and from the stuff I have learned about these diesel wiring harnesses is this meant the alternator was not charging anymore, I started it to deliver a package to the post office and the volt meter showed it not charging.
I looked around the engine compartment and it was not coming out the top, so I removed the pan guard sheet metal and after much talking to myself I finally got it out the bottom, I had to take the 3 mount bolts off, two wires and a plug, the power brake vacuum hose and drain hoses off and the oil feed line, then I had to remove the alternator mount, I even had to tale two of the steering gear bolts out just to get it out the bottom.
So after I got it back in there and I started it before putting the oil pan guard on I started it to see if it would charge, it did charge and I shut it down and finished putting it back together, I put it on the gound and started it, while it was idling I was picking up tools and I started hearing this weird noise, I looked in the engine compartment and seen oil everywhere, I looked under the truck and there was oil everywhere, I shut it down and looked again, all 5 quarts were on the ground, the noise I heard was air coming out the broken oil pressure gauge line.
That hose is brittle, I broke it twice trying to put it back together but I had to because I had to move this truck to clean the driveway up, it took a while but I finally got it all together and filled it with oil and started it, I moved it over and cleaned everything up, it took an hour and a full bag(20lbs) of kitty litter, I moved it back, I am going to have to replace that line before I drive it anywhere, I don't think the engine was damaged as it was only idling and it had not been idling very long without oil, I hope it is not damaged.
I am now thinking that I should go with an electric oil gauge like is in all my other trucks, that plastic oil line is very close to the exhaust in most every direction(turbo in and turbo out), and plastic breaking that easy is not good, I have put a electric sender unit in there before, this line has been in there for over 10 years, maybe closer to 11 years, or I could buy a braided line, in the end I think electric will be cheaper as I might have everything I need already, I will look around tomorrow, I hope I didn't damage the engine, it sounded fine when I started it, it only took a couple seconds to show oil pressure, but that was air coming out that hole making that weird noise, normally I look under the engine after I start it, but today I goofed, I don't recall ever touching that line but I must have as it was broken.
I just changed the oil filter and oil, what a screw up I made not looking under the truck.
The alternator I put in was rebuilt several years ago, I hope it lasts as it is a bitch to get out of there and I don't want to do it again, it took half the day to change out that alternator.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
DRIVEN
Posts: 7138
Joined: Thu Jun 27, 2013 7:05 pm
Location: I've been everywhere
Has thanked: 825 times
Been thanked: 719 times

Re: My 1969 Datsun 521 kingcab diesel

#169

Post by DRIVEN » Sun Nov 29, 2020 5:32 am

Glad it happened in your driveway and not on the freeway. I don't trust those plastic lines at all. I've never had a problem with copper though. It's much cheaper buying it by the foot at the hardware store than prepackaged at the auto parts store.
When the only tool you have is a hammer every problem starts to look like a hippy.

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#170

Post by wayno » Sun Nov 29, 2020 10:11 am

If you buy the copper tubing at the hardware store where do you get the compression fittings for both ends?
DRIVEN wrote:
Sun Nov 29, 2020 5:32 am
Glad it happened in your driveway and not on the freeway. I don't trust those plastic lines at all. I've never had a problem with copper though. It's much cheaper buying it by the foot at the hardware store than prepackaged at the auto parts store.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
DRIVEN
Posts: 7138
Joined: Thu Jun 27, 2013 7:05 pm
Location: I've been everywhere
Has thanked: 825 times
Been thanked: 719 times

Re: My 1969 Datsun 521 kingcab diesel

#171

Post by DRIVEN » Sun Nov 29, 2020 12:27 pm

Usually if a hardware store stocks the (1/8"?) copper tubing, they'll stock some fittings too. You'll probably only need new ferrules and be able to reuse the rest.
When the only tool you have is a hammer every problem starts to look like a hippy.

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#172

Post by wayno » Mon Nov 30, 2020 12:31 am

I went to the auto parts store and spent just over $10.00 to get my truck back on the road, I put the plastic tube in a rubber fuel line and put the rubber fuel line in a wire mesh cover made for fuel lines, the heat in there will not likely do anything to it right now
I bought an electrical sender for the 720 gauges, when it gets here I will convert over to an electric gauge when I feel like it and have the time, I have everything else needed.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#173

Post by wayno » Sun Dec 06, 2020 4:47 pm

I put 266 miles on this today without a hiccup, so I believe I didn't hurt the engine, I received my new dual plug oil sender yesterday, now when ever I want I can switch over to an electrical oil gauge and get rid of the plastic oil line, if it was not on the driver side it would not be near the exhaust manifold, but the other side doesn't have enough room for this large sender with dual purposes, so this is the way it has to be unless I change a few other things.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#174

Post by wayno » Wed Feb 10, 2021 6:09 pm

I have been having an issue with this truck lately, after I drive it a while and shut it down to go inside a store or some other place when I come out and try to start it it will not turn over the engine, I have needed help twice to push start it and it doesn't start like a gas engine, I need a pretty good run at it or be on a hill, so yesterday I made up a bypass of sorts, I put a cable on the motor side of the starter solenoid and tested it to see if the starter motor ran(it was cold) and it did but it did not engage the flywheel, so I put a relay inline and ran another cable to the battery, I threw a hand trigger in the truck and left for some needed supplies, I first went to the paint store using the freeway, when I came out(I was parked on a hill) it would not start, so I wired up the trigger, turned the ignition on and hit the starter and then the trigger and it started right up, I had to use it a couple more times before I got home.
Once the starter solenoid gets warm it will not power the starter but it does engage the flywheel, they are sure using garbage solenoids on starters anymore, I have had the same issue with my L20b starters so I buy used ones now and so far I have been doing alright with them but diesel starters are a lot harder to find used(OEM).

Now I need to wire in a button so I don't need to lift the hood and use the hand trigger.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#175

Post by wayno » Fri Apr 09, 2021 4:16 pm

Well I removed the alternator back in early Nov and now the alternator I put in is not working properly, when not running it has 12.25 volts, when running it has about 12.5 volts, I checked everything I have thought of so far without any positive results, that thing is a bitch to get in and out of there, I have to go in and out the bottom, the thing is I had this alternator rebuilt years ago and that place that rebuilt it no longer exists, I have a few used ones but I do not feel like doing it right now, if I don't use the headlights I am alright as it is not draining the battery, I drove it a few hours today and nothing has changed, the battery is not getting any lower than 12.25 volts when not running and the radio is not cutting out like it does on my work truck when the battery is getting low.

This engine compartment is a bitch to work in, it's great when it is running good, I am tempted to pull the engine transmission and work on them, it has an oil leak, the starter don't work properly, the top starter bolt mount hole in the transmission case is screwed up, the engine compartment is painted black which I regret doing, but it will take time to do/fix all this stuff.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#176

Post by wayno » Sat Apr 10, 2021 10:45 am

Well this is weird, today I started the engine up and it wanted to die again like it did yesterday(it died and I primed it to get it started again), but I floored it and it kept running and then smoothed out, its like the fuel is draining back to the tank and it wants to die from lack of fuel.
Today the light is still on but it is charging better, I now get 13.32 volts when it is running when yesterday I only got 12.5 volts, right now I am hoping if I wait long enough it will fix itself.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

User avatar
wayno
Posts: 4828
Joined: Thu Jun 27, 2013 8:44 pm
Location: Vancouver WA
Has thanked: 277 times
Been thanked: 787 times

Re: My 1969 Datsun 521 kingcab diesel

#177

Post by wayno » Sun Jun 06, 2021 10:01 pm

Well today I spent the whole day trying to find an alternator that worked for this truck, and doing it thru the bottom is a pain, but it would take longer thru the top, the first 2 alternators that I bought from a guy that suggested they were rebuilt did not work, the next one charged great but it was a 3 wire plug type, it started and charged great, but the engine would not shut down, so I went in the shed to my diesel parts tub and found another one that had likely been in there for years, by this time I was getting good at getting them in and out, this one worked properly.

If you all remember I broke the plastic oil line last time I changed one of these out and emptied the oil pan before I realized I had a leak(it was dark), well I had bought one of them dual oil pressure/light senders, so after I got that first alternator out I changed everything and made it an electric oil pressure system to get rid of that line, well after too much time went by I got that part done in the engine compartment and then dealt with 4 installs/removals before finding a good alternator, then I wired and installed the electric oil pressure gauge in the console with it in place, it appears to work fine, I was messing with this for likely 7 hours.

Keep in mind that it is tight going thru the bottom, I have to remove the bolts holding the steering gear on, I can get it out with the alt mount connected, but I cannot get it back in with the mount, the alternator has to go in first, then the mount is mounted, then I mount the alternator on the mount, then I connect the the plug and 2 wires, then the lower drain hose for the vacuum pump, then the oil feed line for the vacuum pump, then the vacuum line for the power brakes, and somewhere in there I put the belt on and tighten it, then I can start the engine it to see if it works, I did all this 4.5 times, once I got one that worked I put the bolts back in that hold the steering gear on, then I put the oil pan rock guard back on that has the horns mounted to it.

I hope this one lasts longer than the last one.

I did this so I can go to the Brooks meet(Canby replacement), I did not believe I could make it back home in the dark using the headlights, it was not charging enough to do that, I actually put the charger on the battery a couple times and it turned over faster after doing that, so starting it was wearing down the battery(local driving), I was going to take my 16" telescope and the refractor I recently bought and look at the sky, it is supposed to be way better there than where I live, but if the sky is not clear or bad seeing I would likely go home Saturday night.
“The difference between genius and stupidly is that genius has its limits” Albert Einstein

Post Reply